


S=ENSTAR. Contents

Contents

(g Lu oo [¥ a1 (o] o FOu SRS S PSR 3

(O 10Tl Q] = 3

Requirements and reCOmMmMENdatioNS.......coceeierieierienieee e s 3

POITADITITY . ueeiieeeieeeeee e s e e st e e e e sbeesaa e e raenare s 3
SEIVEE AP OVEIVIEW....eiiiiiiiiiiiiiitcieete ettt sa e st b e s s b s n e st b s nessnens 4
SAMIPIE COUR. ..ttt ettt et et e b e s st e bt e b e s ate s bt e b e sabe s st ebeenbesatenseensesatenseas 5
MaNAGEA [IDFAIIES...cciiiieiiiieeetere ettt ssbe e s e e e st e e st e e ssae s beesabesbeessseensaenas 9
Media-Streaming lIDrariES. . ...ttt sae s e b e s e e sae e baenee 10
PO S STINCE ..ttt st sttt e bt e s b s bt e s be e rneeas 11
P2 Lo Iy (g =F=1 0 o 1] o Lo BV o [=To TSSOSO PURRPRORN 12
Enable panel SWItChiNG.......oocoiiiiiiiiec ettt sas 13
GEE AN IMAGE ittt ettt sttt s e st e s bt e st e s bt e s b e e se e s bt e e a b e e bt e sabe e ne e e beennne s 14

DECOIratioN OPTIONS..c..eiiiieiiieiieeee ettt st s b s bt e st s be e s b s sab e sbeessnesreesane 14
ACLIVATE @ FRIAY . c.ueiieiicieeeece ettt st e e st e e st e e s ae e s ae e sate s baesaaeenraeearaenns 15
ENADIE @ CAME@IA TOUN.c..iiiiiiicieeee ettt s b e st 16
Wrap @n OCX iN @ DLLuuuuiiiiiiieeiieeieeeeeete ettt ettt b e saa e s b e sab e s neesanes 17
Legal INTOIMIATION.....iieiiieieeeee ettt sttt ettt be st s b s bt e et eneans 21

eecoe

Senstar Symphony SDK User Guide 2



S=ENSTAR. Inroductin

Introduction

The Senstar Symphony SDK allows you to integrate and extend Symphony.

The Symphony Client uses these same methods to ensure quality and feature completeness. Sample
applications are included for a wide variety of use cases. Reference documentation is provided in
<SDK>/Documentation/readme.html.

Quick start

Running a Symphony SDK application

Create an Xnet account.

Download and install the Symphony Server and Symphony Client.

Use a Web browser to access the server configuration interface and add a camera to Symphony.
Download and install the Symphony SDK.

If you install the Symphony SDK on a computer without the Symphony Server or Client, open
a command prompt in the Symphony SDK bin folder (C: \Program Files (x86)\Senstar
\Symphony SDK\bin by default) as an administrator and run the following command:

ukhwn =

for %$x in (*.dll *.ax *.ocx) do regsvr32 /s %x

6. RunLiveStreamTest.exe inthe Symphony SDK to see live video from Symphony.

Compiling a Symphony SDK application

1. Open SDK.sln in Visual Studio.
2. Right-click LiveStreamTest in the Solution Explorer and click Set as Startup Project.
3. PressF5.

Requirements and recommendations

+ The managed interfaces must be from executables that target .NET 4.5.2 or later.

* Therecommended IDE is Visual Studio 2012 or later.

+ The recommended programming language is C#.

+ The developer should be familiar with Symphony.

« Itis recommended that Symphony and the Symphony SDK are installed on different computers.

Portability

It is possible to integrate live video from Symphony directly from non Windows platforms using
GStreamer and the RESTful Mobile Bridge interface. Please contact us for details about GStreamer.

The portable Mobile Bridge interface is not as full featured as the Windows accessible SeerWs
interface. If you need functionality in SeerWsS from non Windows platforms, then you must develop
your own layer that provides this interface. Ported implementations of .NET will work (such as
Mono), but the referenced .NET libraries link to Windows style DLLs which require deeper platform
equivalence.

00000
Senstar Symphony SDK User Guide 3



S=ENSTAR.

Server API overview

Server API overview

Al InfoService

Info and Control
(AiraWs3)

Access Control
Alarms
Backup/Restore
Bookmarks
Carousels

Device

Device Groups
Events

Farm

Footage management
JPGs

Map

Plug-ins

PTZ

Rules

Search

Security

Service management
Speaking and playing audio
Timeline

User Groups

Users

Video Analytics
Video settings

Video Wall
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{INotificationSource)

Alarms Occurred
Bookmarks Changed
Timeline Event Occurred
Camera PTZ Controlled
Camera Configuration Changed
Camera Sequence Changed
Camera Tour Changed

Farm Changed

Farm State Changed

Instant Message Occurred
Maps Changed

Rules Changed

Security Profile Changed
Active Profile Changed
Users Changed
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Sample code

Sample code

Server farm connectivity

Use cases

Connect to a server farm

SDK projects

NotificationMonitorExample

FarmTest

Video
Get a list of cameras LiveStreamTest
FarmTest
Connect and render live video LiveStreamTest
Connect and render historical video LiveStreamTest

Get a historical JPG

AlarmHandlerExample

Export video

ExportVideo

PTZ cameras

Use cases SDK projects

Control PTZ on a video device LiveStreamTest
FarmTest

Load guard tour locations LiveStreamTest
FarmTest

Go to a specific guard tour location LiveStreamTest
FarmTest

Events

Use cases

Trigger an alarm

SDK projects
AddAlarmToCamera

FarmTest

Listen for alarms

AlarmHandlerExample
MobileBridge
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Sample code

Use cases SDK projects
Get a list of alarms LiveStreamTest
Mark an alarm LiveStreamTest

Listen for farm events

NotificationMonitorExample
NotificationMonitors
MobileBridge

Farm settings
Use cases

Retrieve farm settings

SDK projects

WebService

Execute a web service method

WebServiceConsole

Recording

Use cases

Start/stop recording

SDK projects

LiveStreamTest

FarmTest

Symphony Client control

Use cases

Switch cameras in Symphony Client through
Server API

SDK projects
VideoWall

FarmTest

Switch cameras in Symphony Client through
Client API

VideoWallClient

Reports
Use cases

Get a heatmap

SDK projects

GetDensityImage)pg

Security
Use cases

Change the currently active security profile

SDK projects

SetActiveProfile

Add/remove users

UserManagement
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Video analytics

Sample code

Use cases SDK projects

Get live XML metadata from a running analytics
engine

XMLStream

Analyze video in Symphony from a third-party
video system

AlgorithmIntegration

Load a Symphony UI component in a third-party |PluginHost
application

Incorporate your own analytics engine AlgoSample
Incorporate your own rules engine AlgoSample

TestRuleEngine

Incorporate your own analytics engine
configuration

AlgoSampleConfiguration

Incorporate your own rules engine configuration

AlgoSampleConfiguration

Timeline
Use cases

Get timeline information

SDK projects

TimelineGetter

Navigation

Use cases

SDK projects

Use navigation buttons to control video

FarmTest

DIO rules

Use cases

Import/export DIO rules from/to a CSV file

SDK projects

AddDIORulesFromCSV
ExportDIORulesToCSV

Hardware devices

Use cases SDK projects

Get a list of all hardware devices

PSA

Add a new hardware device

PSA
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Camera usage

Use cases SDK projects

View camera-use information ClientBandwidth

Direct file access (persistence)

Use cases SDK projects

Show detailed footage file frame information PrintFootageFile
Show detailed timeline file information PrintSignalsFile
Show detailed metadata file information PrintSignals2File
Show detailed export file information PrintAiraFile
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Managed libraries

The Symphony SDK uses the following managed libraries:

Component Description

Seer.Connectivity.dll « Library for connecting to Symphony servers (usually used
indirectly by samples)

Seer.BaselLibCS.dll ¢ Seer.BaseLibCS.Communication.ServerConnectionManagerfOF

client-server connectivity (usually used indirectly by samples)
* Seer.BaseLibCS.AiraWs.Signals for Web service interface
®* Seer.BaseLibCS.CameraMessageStruct for structure definitions
* Seer.BaseLibCS.Utils.MulticastMessage fOr constants

Core.dll * Source part of the Symphony SDK
* seer.SDK.SDKFarm fOr farm connectivity and event stream
notifications

Seer.Farm.dll * Seer.Farm.DeviceModel.Client fOr client-side device operations
and information

* Seer.Farm.DeviceModel.Server fOr server-side device operations
and information

Internationalization.dll * Seer.Internationalization.Translator fOr Ianguage translation
into all supported languages

NotificationMonitors.dll + Source part of the Symphony SDK
+ Interface to the event stream that comes from Symphony

The following managed libraries are dependencies of the above libraries and likely do not need to be
used by your code directly. However, you might need to add them as references to your project. If
they do need to be added, the compiler will fail with a message stating what reference needs to be
added.

® Seer.Common.dll

®* DeviceModel.Dio.dll

* DeviceModel.Security.dll
®* Farm.Security.dll

®* SecurityLib.dll

The following managed libraries enable access to video streaming.

* AxVideoRecvCtrl.dll WrapsS videoRecvCtrl.dll
* BaseIDL.d11 iS a set of COM interfaces that aid in streaming video

00000
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Media-streaming libraries

Component Description

AxVideoRecvCtrl + ActiveX control that supports the Dispatch interface
+ Can be used by simple applications such as VB or Web-based
applications
IvideoRecvCtrl + A COM interface exposed by axvideorecvctrl
+ Supports richer API when combined with 1NetworkEndpoint and
IHistoricalSeek

+ This interface is demonstrated by the LiveStreamTest sample
* This is the recommended interface

0CXD11.dll « Library that allows users ti dynamically create, use, and
destroy axvideorecvCtrl

OCXExe.exe « An executable that shows how to use ocxpi1.d11

+ Useful if you need to support multiple NVRs and need a library
with a common API for each NVR
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Persistence
Files
Files Description
_FootageArchive (*.dat) + Video
* Audio
 Overlays (decorations)
_Signals (*.dat) + Timeline data
_Signals2 (*.dat) + Metadata (usually from video analytics)
Exported movie files (+.aira) + Video
+ Audio
 Overlays (decorations)
Database
Data Description
Settings « Most settings (except users, groups, and
servers)
Servers + All servers and server states in a farm
Alarms « All alarms
XnetData * License information
ObjectCounts + Count of objects per minute (video analytics)
LineCounts « Count of line crossings per minute (video
analytics)

You can use pbupdater.exe from the command line to run SQL against the database.
dbupdater "select top 10 * from settings order by sequenceid desc"

Shows the last ten settings that have changed.
dbupdater "select * from servers"

Shows all server addresses and states in the farm.

dbupdater "select count(*) from alarms"

Shows the current count of all alarms.

All database times are UTC encoded as the number of seconds (or milliseconds) since 1970. Run
dbconfiguration.exe to view or change the current database connection string.

00000
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Add streaming video

You can use the Symphony SDK to add streaming video to a project.

Open the design view of the form to which you want to add the control.
From the Tools menu, click Add/Remove Toolbox Items.

Click the COM Components tab.

Select the VideoRecvCtrl Control box.

Click OK.

The ActiveX control appears in the toolbox in the Windows Forms section.
6. Drag the ActiveX control onto the design view.

vk W~
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Enable panel switching

You can use the Symphony SDK to enable panel switching in the Symphony client interface.

1. Perform one of the following tasks:
+ To switch video panels using the Symphony Server, use the FarmTest or VideoWall
application.
+ To switch video panels using the Symphony Client, use the VideoWallClient application.
2. Ensure that the user has Video Wall Change Panel permissions.

3. Toregister the Symphony Client in which the video panel switch will occur as a video wall client,
complete the following steps:

a) Inthe Symphony client interface, click Settings > Video Wall.
b) Click the Video Wall Client Configuration tab.
c) Click Register current Symphony Client.
4. To get the panel name, complete the following steps:
a) Inthe Symphony client interface, right-click the panel and click Settings.
b) Click the Child tab to display the panel name.

If you use the VideoWall application in the command prompt and the panel name includes
a space, surround the panel name with double quotes (e.g., "panel name").

5. Use one of the following IP addresses:

+ Inthe FarmTest and VideoWall applications, use the IP address of the Symphony Server.
+ Inthe VideoWallClient application, use the IP address of the Symphony Client.
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Get an image

You can use the Symphony SDK to get a JPEG image from a project.

1. Use the cetgprc command to generate a JPEG image and return its URL.

2. Use the cetgrecImage cOmmand to get the byte array of a JPEG image for a specific time and
camera.

3. Use the cetorEcImage3 command to extend the cetgrEcimage cOmmand and add parameters for
the decorations.

4. Use the getgprEcImage4s cOmmand to extend the getJpecimage3 command and add parameters for
the font used on the image.

Decoration options

The following parameters determine the decorations that JPEG images include.

DecorationOptions options = new DecorationOptions (15, 0, true, 0, true);
// Pass decorations. EncodedDecorationOptions to GetJPEG* functions

// You will want to use the following DecorationOptions constructor
public DecorationOptions (int decorations, int dateFormat, bool in24HourNotation, uint
streamIndex, bool canViewPrivateVideo)
{
// BITWISE OR together the following to select decoration

// 1 = rectangles.
// 2 = messages.
// 4 = time.

// 8 = paths.

_rawDecoration = decorations;

// SET to one of the following
// 0 = yyyy/MM/dd

// 1 dd/MM/yyyy

// 2 MM/dd/yyyy

_dateFormat = dateFormat;

// True for 24 hour time format. False for 12 hour time format.
_in24HourNotation = in24HourNotation;

// 0 based stream number. The Symphony Client UI is 1 based.
_streamIndex = streamlIndex;
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Activate a relay

To activate or deactivate a relay, call the following Web service method:
public void PerformAction(string username, string password, string sActionReq)

To activate a relay, sactionreq Uses the following format:
<action><ServerIP>10.234.8.30</ServerIP><camera><On Relay='l' DevicelD='2"'/></camera></action>

To deactivate a relay, sactionreq uses the following format:

<action><ServerIP>10.234.8.30</ServerIP><camera><Off Relay='l' DevicelD='2"'/></camera></action>
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Enable a camera tour

To enable or disable a camera tour, use the following SQL command:

declare @xml xml, @camerald int, @tourName varchar (250), @disabled int;

set @camerald = 3;

set @tourName = 'Camera Tour 2';

set @disabled = 1;

select @xml = CAST (v as xml) from settings where Type = 'Camera' and Section = 'Camera' and K =
'cameraTour' and ID = @camerald;

set @xml.modify('replace value of (/TourGroup/cameraTour [@name=sqgl:variable(''@tourName'')]/

disable/text()) [1] with sgl:variable(''@disabled'')"):;

update Settings set V = CAST (@xml as nvarchar (max)) where Type = 'Camera' and Section = 'Camera'
and K = 'cameraTour' and ID = (@camerald;

To run a batch file on the Symphony Server, pass the following command to the dbupdater utility:

dbupdater "declare @xml xml, @camerald int, @tourName varchar (250), @disabled int;

set @camerald = 3;

set @tourName = 'Camera Tour 2';

set @disabled = 1;

select @xml = CAST (v as xml) from settings where Type = 'Camera' and Section = 'Camera' and K =
'cameraTour' and ID = (@camerald;

set @xml.modify('replace value of (/TourGroup/cameraTour[@name=sqgl:variable(''@tourName'')]/

disable/text()) [1] with sgl:variable(''@disabled'')");

update Settings set V = CAST(@xml as nvarchar (max)) where Type = 'Camera' and Section = 'Camera'
and K = 'cameraTour' and ID = (@camerald;"

Senstar Symphony SDK User Guide
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Wrap an OCXin a DLL

Wrap an OCX ina DLL

Create an MFC DLL project:

a) Click File > New > Project.

b) Expand Visual C++ and click MFC.

c) Click MFC DLL.

d) Type ocxDLL in the Name field and click OK.

e) Click Finish.

Add a dialog to the DLL:

a) Inthe Resource View window, right-click OCXDLL.
b) Click Add > Resource.

c) Select Dialog and click New.

d) Inthe dialog, delete the OK and Cancel buttons.
Change the default properties of the dialog:

a) Right-click the dialog.

b) Click Properties.

c) Change the border to none.

d) Change No Fail Create to True.

e) Change Style to True.

Add a dialog class:

a) Right-click the dialog.

b) Click Add class.

c) Type OCxDLLDialog.h inthe Name field and click Finish.
d) Add#include "resource.h"in OCXDLLDialog.h.
Add the OCX control:

a) Select the dialog tab.
b) Inthe Toolbox window, right-click Choose Toolbox Items.
c) Click COM Components > VideoRecvCtrl Control.

The file is videoR~2.0Cx and is located in the aira\bin directory.
d) Drag the control on to the dialog and re-size it to fill the space.
Add a variable to the OCX:

a) Right-click the VideoRecvCtrl control.

b) Click Add Vvariable.

c) Change Access to protected.

d) Inthe Variable Name field, type m_ocCx.

e) Click Finish.

Add play and stop functions:

a) IntheocxDpLLDialog.h file, add the following as public declarations:

HRESULT Play(unsigned long IP, unsigned short port, LPCTSTR user, LPCTSTR pass,
_int64 historicalTime);
HRESULT Stop (void) ;

b) Inthe ocxpLLDialog.cpp file, add the following methods:

HRESULT OCXDLLDialog::Play(unsigned long IP, unsigned short port, LPCTSTR user,
LPCTSTR pass, __ int64 historicalTime)
{
HRESULT hr;
if (FAILED(hr = m OCX.Init()))
return hr;
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if (FAILED (hr = m OCX.Connect (IP, port, user, pass, historicalTime)))
return hr; -
if (FAILED(hr = m OCX.StartVideo()))
return hr;
return S OKj;
}

HRESULT OCXDLLDialog::Stop (void)
{
HRESULT hr;
if (FAILED(hr = m OCX.StopVideo()))
return hr;
if (FAILED (hr = m OCX.Destroy()))
return hr; B
return S_OK;

}

In the ocxDLL. cpp file, add a call to AfxEnableControlContainer() in Initinstance().
Create an interface for the VideoCreate, VideoDestroy, VideoPlay, and VideoStop functions.

a)

)
)
)

o 0O T

In the Solution Explorer, right-click Header Files.

Click Add > New Item.

Add a new header file called 0OCxXDLLInterface.

Copy the following code into the oCxXDLLInterface header file:

#pragma once

#ifdef OCXDLL EXPORTS

#define OCXDLL API _ declspec (dllexport)

#else

#define OCXDLL API _ declspec(dllimport)

#endif

#include "OCXDLLDialog.h"

OCXDLL API OCXDLLDialog*VideoCreate (CWnd *parent);

OCXDLL API HRESULT VideoDestroy (OCXDLLDialog *wnd) ;

OCXDLL API HRESULT VideoPlay (OCXDLLDialog *wnd, unsigned long IP, unsigned short
port, LPCTSTR user, LPCTSTR pass, _ int64 historicalTime);
OCXDLL API HRESULT VideoStop (OCXDLLDialog *wnd);

In the Solution Explorer, right-click Source Files.

Click Add > New Item.

Add a C++ file called oCXDLLInterface.

Copy the following code into the 0CXDLLInterface C++ file:

#include "stdafx.h"
#include "OCXDLLInterface.h"
#include "OCXDLLDialog.h"

OCXDLL API OCXDLLDialog*VideoCreate (CWnd *parent) {
AFX MANAGE_STATE (AfxGetStaticModuleState()) ;
OCXDLLDialog *wnd = new OCXDLLDialog() ;
wnd->Create (OCXDLLDialog: : IDD, parent);
return wnd;

}

OCXDLL API HRESULT VideoDestroy (OCXDLLDialog *wnd) {
AFX MANAGE STATE (AfxGetStaticModuleState());
wnd->DestroyWindow () ;
delete wnd;
return S_OK;

}

OCXDLL API HRESULT VideoPlay (OCXDLLDialog *wnd, unsigned long IP, unsigned short
port, LPCTSTR user, LPCTSTR pass, _ int64 historicalTime) {

AFX MANAGE_STATE (AfxGetStaticModuleState()) ;

return wnd->Play(IP, port, user, pass, historicalTime);

}

OCXDLL API HRESULT VideoStop (OCXDLLDialog *wnd) {
AFXiMANAGEisTATE(AfoetStaticModuleState());
return wnd->Stop () ;
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10. Add OCXDLL_EXPORTS to the list of preprocessor definitions for the project:

a) Right-click the project.

b) Click Properties.

c) Expand C/C++ and click Preprocessor.

d) AddocxDLL EXPORTS to the preprocessor definitions.
11. Add a dialog-based MFC application project:

a) Click File > Add > New Project.

b) Expand Visual C++ and click MFC.

c) Click MFC Application.

d) Type ocxexE and click OK.

e) Click Next.

f)  Change the application type to Dialog based and click Finish.

12. Add buttons:

a) Inthe Resource View window, expand OCXEXE > OCXEXE.rc > Dialog.

b) Double-click IDD_OCXEXE_DIALOG.
c) Delete the following items:

« OK button
+ Cancel button
+ TODO: Place dialog controls here text

d) Increase the width of the dialog windows to fit two OCX controls.
e) Using the toolbox, drag three new buttons to the dialog.

f)  Change the following properties for the new buttons:

Caption: Add Video
ID: IDB_ADD

Caption: Start
ID: IDB START

Caption: Remove Video
ID: IDB REMOVE

13. Add a variable to the dialog:
a) Right-click the dialog.
b) Click Add Variable.
c) Select the Control variable box.
d) Inthe Variable Name field, type m btnadd.
e) Verify that the control ID is IDB_ADD.
f)  Click Finish.

Wrap an OCX ina DLL

14. To add the OnBNClickedAdd, OnBNClickedRemove, and OnBnClickedStart methods to the

OCXEXED1lg.cpp file, double-click each of the new buttons.
15. Inthe OCXEXEDlg.h file:

Add the required header files and std namespace:

#include <vector>
#include "..\OCXDLL\OCXDLLInterface.h"
using namespace std;

Add the following protected member:

vector<OCXDLLDialog*> m_windows;
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16. Inthe OCXEXEDlg.cpp file:
Modify the OnBnClickedAdd, OnBnClickedRemove, and OnBnClickedStart methods as follows:

void COCXEXEDlg::0nBnClickedAdd ()

{
OCXDLLDialog *dlg = VideoCreate (NULL) ;

dlg->SetParent (this);
dlg->ShowWindow (SW_SHOW) ;
dlg->MoveWindow ( (m windows.size() & 1) * 250, (m windows.size() & 2) * 50, 250, 100);
m_windows.push back (dlg) ;
}

void COCXEXEDlg::0nBnClickedRemove ()
{
if (m windows.size() > 0) {
OCXDLLDialog *dlg = m windows.back();
m_windows.pop back() ;
dlg->SetParent (NULL) ;
VideoDestroy (dlg) ;

}

void COCXEXEDlg::0nBnClickedStart ()
{

if (m windows.size() > 0) {
// This will connect to live video on localhost (127.0.0.1), camera #1, using user
“admin” and password “admin”
VideoPlay (m windows.back(), 0x7F000001, 50010, T ("admin"), T("AlcrUF4="), 0);

}
}

17. Inthe OCXEXE. cpp file, call cotnitialize (nunL) after aAfxEnablecControlContainer () iN

InitInstance ().

18. Inthe Solution Explorer:
a) Right-click the OCXEXE project.
b) Click Project Dependencies.
c) Select OCXDLL as a dependency.
d) Right-click the OCXEXE project.
e) Click Set as StartUp Project.

To connect to the camera, you might need to modify the camera details for the
OnBnClickedStart method in the OCXEXED1g. cpp file.
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Legal information

Copyright © 2019 Senstar Corporation and/or its Licensor(s). All rights reserved.

This material is for informational purposes only. Senstar makes no warranties, express, implied or
statutory, as to the information in this document.

Complying with all applicable copyright laws is the responsibility of the user. Without limiting the
rights under copyright, no part of this document may be reproduced, stored in or introduced into a
retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying,
recording, or otherwise), or for any purpose, without the express written permission of Senstar
Corporation

Senstar may have patents, patent applications, trademarks, copyrights, or other intellectual property
rights covering subject matter in this document. Except as expressly provided in any written license
agreement from Senstar, the furnishing of this document does not give you any license to these
patents, trademarks, copyrights, or other intellectual property.

Portions of this software are based in part on the work of the Independent JPEG Group.

All other trademarks are the property of their respective owners.
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